Press "Enter" to skip to content

Les navigateurs sont-ils compatibles avec Vue JS ?

Les composants Syncfusion Essential JS 2 ne sont pris en charge que dans les navigateurs modernes. Cela inclut les versions suivantes….Polyfills requis.

Navigateur Polyfills
Chrome (dernier), Firefox (dernier), Opera (dernier), Edge, Safari 9+ RIEN
Internet Explorer 11 Promesse ES6

Q. Est-ce que Vue JS est sûr ?

Mon entreprise utilise Vue. js depuis plus d'un an et nous n'avons jamais rencontré de problème sérieux jusqu'à présent. Sur la base de ces faits, je peux dire qu'il est très sûr d'être utilisé sur des projets personnels ou même sur la production. Pour tout type de projet open source comme Vue.

Q. Quelle est la version actuelle de Vue JS ?

Vue. js

Auteur(s) original(s) Evan vous
Première version Février 2014
Version stable 3.2.1 / 9 août 2021
Dépôt github.com/vuejs/vue-next
Écrit en Manuscrit

Q. Qu'est-ce que VUE JS pour les débutants ?

VueJS est un framework JavaScript open-source qui est généralement utilisé pour développer des interfaces interactives. D'un point de vue MVC, tout en développant avec VueJS, il se concentre sur la partie vue.

Q. Est-ce que Vue prend en charge IE ?

La principale raison pour laquelle votre application Vue se brise dans IE11 est que le navigateur ne prend pas en charge la syntaxe JavaScript moderne. J'entends par là ES2015 et au-delà. Le navigateur Internet Explorer a été abandonné au profit du navigateur Edge plus moderne de Microsoft.

Q. Quels navigateurs sont pris en charge par Vue ?

Navigateurs

Navigateur Statut
Firefox Prise en charge
Safari 10+ Prise en charge
IE11/Safari 9 Pris en charge avec polyfill
IE9 / IE10 Non supporté

Q. Le v-HTML nettoie-t-il ?

C'est là qu'intervient vue-sanitize. Non seulement il vous permettra d'utiliser une liste blanche de balises HTML "sûres", mais il supprimera les balises non autorisées plutôt que de les échapper. Cela renverra une chaîne avec les balises HTML non sécurisées supprimées. Vous devez toujours utiliser v-html pour rendre le HTML sûr bien sûr.

Q. Pourquoi mon Vue n'est-il pas reconnu dans IE 11 ?

En le recherchant, j'ai découvert que la balise de modèle n'est pas reconnue dans ie (11). Alors, j'ai essayé d'incorporer le remplacement 'script type=x-template' pour la balise de modèle, mais je n'ai pas réussi à le faire fonctionner. Mon instanciation de vue est dans main.js, où mes itinéraires sont également définis.

Q. Que faire si l'application Vue ne fonctionne pas ?

Pour l'utiliser, créez un fichier vue.config.js dans le répertoire racine de votre projet (si vous n'en avez pas déjà un) et ajoutez ceci : Bonjour LinusBorg, merci encore pour l'aide, cela semble mener à une solution. Mais après avoir fait comme vous l'avez expliqué, j'ai maintenant des erreurs différentes et l'application Vue ne s'exécute dans aucun navigateur.

Q. Y a-t-il un problème avec le chargeur app.vue dans IE11 ?

Mais vous parlez d'avoir un problème avec app.vue, ce qui n'a aucun sens car IE11 n'obtient jamais aucun contact avec app.vue – vue-loader le transforme avant qu'IE11 ne reçoive le bundle. Je ne vois donc pas comment IE11 devrait affecter tout cela.

Q. Où puis-je trouver le plugin Babel dans Vue CLI ?

La documentation indique que les applications vue créées à partir de vue-cli utilisent @vue/babel-preset-app et sont répétées sur la page github, indiquant qu'elles sont déjà incluses dans chaque application créée par vue-cli, dans node_modules. Cependant, il existe un autre plugin de préréglage Babel.